Diagrams on New Jobs Delayed

Incident Report for Partly

Resolved

The backlog has been cleared, performance should be back to normal now.
Posted Jul 24, 2026 - 13:05 NZST

Identified

We are experiencing an unusual burst in demand, new jobs will take longer than usual to have diagrams.

We are working to scale capacity to prevent this recurring in the future. Thank you for your patience!
Posted Jul 24, 2026 - 11:51 NZST
This incident affected: Repair App and Workshop.